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Year End Questions - General 

Q1. Can users be in the system when performing year end? 

A2. It is strongly recommended that no users are in the system when performing a year end Process. 

Q2. Can budgets be imported before the year end and also can FRX reports be changed to show these 

figures? 

A2. Yes budgets can be imported before year end and also FRX can be changed to look at the budget rather 

than the actual 

Q3. What is the year end process for Microsoft GP Project Accounting? 

A3. There is no year-end process for Microsoft GP Project Accounting. 

Q4. I need to run year-end closing for 4 companies.   Do users have to be out of all companies when 

running this - or just the company that the year-end is being run in at the time? 

A4. The users only have to be out of the company that you are running the year-end process in. 
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Receivables Management  

Q1. Must I run the Receivables Management year end routine at the year end?  

A1. No, the receivables year end is not run for a particular year, it runs up to the current date, i.e. today’s 

date. It is not a requirement to close this sub-ledger if you do not use the information in the Customer 

Summary enquiry window. 

Q2. Must I run the Receivables Management year end routine before I enter receivables transactions 

in the new financial year?  

A2.  No, you can post to the new-year before receivables year end is run. Only thing to consider is the YTD 

field in the Customer Summary Enquiry window could be inaccurate. (See receivables manual for more 

details) 

Q3.  Can the Receivables Year-End Closing Report be reprinted after the year-end close has been 

completed? 

A3.  No, this report can only be printed at the time of the year-end close.  There is no way to reprint it again 

later.   

Q4.  Do we have to run a check links and reconcile routine on the sales series? 

A4.  These routines are recommended.  
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Payables Management  

Q1. Must I run the Payables Management year end routine at the year end?  

A1. No, the Payables year end is not run for a particular year, it runs up to the current date, i.e. today’s date. It 

is not a requirement to close this sub-ledger if you do not use the information in the Creditor yearly 

summary enquiry window. 

Q2. Must I run the Payables Management year end routine before I enter payables transactions in the 

new financial year?  

A2.  No, you can post to the new-year before payables year end is run. Only thing to consider is the YTD field 

in the Creditor yearly summary enquiry window could be inaccurate. (See payables manual for more details) 

Q3.  Can the Payables Year-End Closing Report be reprinted after the year-end close has been 

completed? 

A3.  No, this report can only be printed at the time of the year-end close.  There is no way to re-print this 

report. 

Q4.  Do we have to run a check links and reconcile routine on the payables series? 

A4.  These routines are recommended. 
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Inventory Control  

Q1. Must I run the Inventory year end process at Year end? 

A1. No, it is not a requirement to close this sub-ledger if you do not use the information in the Item History 

window. 

Q2.  Must I run the Inventory year end routine before I enter inventory transactions in the new 

financial year?  

A2.   It is recommended that the Inventory Year End routine process is run before transactions are entered in 

the new financial year.  If this is not done the information on the Item History (Cards > Inventory > History) 

will not be correct.  If you do not use the information in the Current Year and Last Year columns on this field 

then it is not necessary to close inventory before new inventory transactions are entered.  

Q3. Will marking to remove Discontinued Items on the Inventory Year End Closing window remove 

the history for these items?  

A3. Yes, the system will automatically remove both transaction and distribution history for these items. 

Normally, you would not be able to delete these items manually unless you first removed the transaction and 

distribution history through the Remove Transaction History utility (Tools > Utilities > Inventory > Remove 

Transaction History). 

Q4.  When performing the Inventory Year End Closing routine (Tools >Routines > Inventory > Year-

End Close), I choose Discontinued Items for my Remove option however, the discontinued items did 

not get removed.  Why? 

A4.  If any of the discontinued items are components of kits, they will first need to be removed as 

components of the kits.  You can use the Component Report (Reports > Inventory > Items > Kit List) to 

identify the components.  To remove the item from the kit you need to use the Item Kit Maintenance window 

(Cards > Inventory > Kits).  Select the kit item and find the discontinued item component.  Highlight the item, 

and choose Edit > Delete Row to remove it as a component and save the changes.    

Next, check if the items are finished goods or components of bills of materials:   

A) The BM Component Where-Used Report (Reports > Inventory > Setup > Component Where Used) can be 

used to identify which discontinued items are components of bills of materials.  In the report option, all Bill 

and Component Statuses should be checked: Active, Pending, and Obsolete. 

If any of the discontinued items are components of a bill of materials, the components need to be removed 

from the bills.  This is true for all Statuses of the bills and components, including Active, Pending, and 

Obsolete.  The components can be removed by going to Cards > Inventory > Bill of Materials, select the bill 

and the status and then find the component in the scrolling window.  Click in the line, and choose Edit > 

Delete Row from the menu bar and save the changes. 

B) The BM Bill of Materials Report (Reports > Inventory > Setup > Single-level Bill of Materials) can be used 

to find which discontinued items are bills of materials. In the report option, all Bill Statuses should be 

checked: Active, Pending, and Obsolete. 

If any of the discontinued items are bills of materials, the bill needs to be deleted.  This is true for all bill 

statuses, including Active, Pending, and Obsolete.  The bill can be deleted by going to Cards > Inventory > 

Bill of Materials, select the bill and the status, then click Delete and confirm. 
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Q5.  I am trying to do a year-end close in Inventory and the following message appears: ‘This process 

can not be run while invoices are being posted’. There are no invoices being posted. What can I do?  

A5.  Get ALL users out of Dynamics GP and run the following delete statements in Query Analyser: 

USE TEMPDB 

GO  

DELETE DEX_LOCK  

DELETE DEX_SESSION  

USE DYNAMICS 

GO 

DELETE ACTIVITY 

DELETE SY00800 

DELETE SY00801 

Q6.  How is the average cost of an item updated throughout the year and during the year-end closing 

process when using the average perpetual method of costing? 

A6. If you are using the average perpetual costing method, all receipts for each item will be averaged to 

determine the average cost. Even if quantities are sold, the average does not change until another purchase 

receipt for the item is posted to the Inventory Purchase Receipts file. The year-end closing process does not 

change the average cost, but it will remove the purchase receipts that have been completely sold. The next 

time a receipt is entered, the average cost will be revalued with the receipts that remain in the Inventory 

Purchase Receipts File.  

Q7: Can the Inventory Year-End Closing window (Tools > Routines > Inventory >Year-End Close) be 

used throughout the year to update the standard cost of items if using the periodic valuation method?  

A7: This is not recommended because the beginning quantity field is updated during the year-end closing 

process. This would make that field incorrect on reports such as the Turnover Report. 
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Fixed Asset Management 

Q1. Must I run the Fixed Asset year end routine before I enter transactions in the new financial year?  

A1.  No, Fixed Assets year end closing can be run at a later date. However, you will not be able to run 

depreciation for the new financial year until this procedure has been run.  

Q2.  Must I run the Fixed Asset Year End Closing routine for all Asset Books at the same time?  

A2.  No, you can run the Year End Closing routine on your books at different times. However, you will not be 

able to run depreciation in the book for the new financial year until this procedure has been run.  

Q3. Can fixed assets module be closed off before any other modules? 

 A3. Yes. The only module you need to consider closing before Fixed assets is         Payables Management to 

ensure all transactions coming from Payables have been capitalised in the Fixed Assets system (if you are 

using the interface from purchasing to FA).  

Q4. Can I undo an asset that’s been retired in the previous fiscal year? 

A4. No, the system allows you to retire an asset as of a prior fixed assets fiscal year, but it does not allow you 

to undo retirement as of a prior fixed assets fiscal year.  

The workaround for this is to delete the Fixed Asset and then set it up again following the steps below:  

 

1. Print the Fixed Assets to General Ledger Reconciliation report for this asset - (Reports > Fixed Assets > 

Activity). Choose the asset and print the report to see the information that has interfaced to the General 

Ledger for this account.  

 

2. Delete the Asset (Utilities > Fixed Assets > Delete), this will completely remove the Fixed Asset but will not 

change any figures in the General Ledger.  

 

3. Verify that everything has been interfaced to the General Ledger for all assets. If it has not you will want to 

interface all of the data to the General Ledger so only this assets changes will be interfaced in step 6.  

 

4. Enter the asset (Cards > Fixed Assets > General) and book record (Cards > Fixed Assets > Book) and 

Depreciate the asset (Routines > Fixed Assets > Depreciate One Asset) to the point it was depreciated before.  

 

5. Run the GL Interface and delete this batch as the depreciation had already been accounted for in the 

General Ledger. You can verify this from the Fixed Assets to General Ledger Reconciliation report that you 

printed in step 1.  

 

6. Retire the asset using the correct date.  

 

7. Run the GL Interface for the retirement and post this information to the General Ledger, as this had not yet 

been posted to the GL. 
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Q5. I processed the Fixed Assets Year-End routine and have run depreciation in the new year. I noticed 

that the depreciation is highly overstated and some of my assets have a negative Net Book Value. 

Why is the system calculating so much depreciation?  

A5. This will happen if the year was closed and the assets were not depreciated through to the very last day 

of the financial year. For example, if the financial year is a calendar year (January 1 – December 31) and the 

assets were depreciated through 

December 28 when the year was closed, depreciation will be incorrect the next time it is run. The system does 

not recalculate the yearly rate when the year-end routine is performed; therefore, it will take a full year’s 

worth of depreciation (the yearly rate currently on each asset) in the last few days remaining in the previous 

year (December 29– December 31). If there are assets near the end of their original life, it can cause the Net 

Book Value to go negative as well.  

There are a couple of solutions available if this situation is encountered. The first (recommended) solution 

would be to restore the data from a backup, run depreciation through the very last day of the year, and 

perform the year-end procedure. The other solution would be to reset life on all of the assets. However, if 

amounts have ever been plugged for YTD and LTD Depreciation on the assets, resetting the life would 

change those amounts and the end result may be different. This will cause inconsistencies between the Fixed 

Asset module and the General Ledger which would need to be accounted for.  
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Q6.Instead of going through the year-end routine for Fixed Assets, I manually changed the Current 

Fiscal Year field in the Book Setup window to the next year. Do I need to go back and run the year-

end routine or can I continue processing activity in Fixed Assets for the new year?  

A6. No, the year-end routine needs to be run. If it isn’t, then the YTD Depreciation Amount will be overstated 

on any report that includes assets that were retired or fully depreciated in the previous year. When the year-

end close is not performed, the YTD Depreciation amounts will not be removed (zeroed out) so they will be 

incorrectly included on the reports for the new year. To fix:    

i. If no activity (additions, changes, transfers, retirements, and/or depreciation) have been run for the 

new year, the Current Financial Year field in the Book Setup window can be changed back to the 

previous year and the year-end routine can be processed.                                                                                              

ii. If activity (additions, changes, transfers, retirements, and/or depreciation) have been run for the new 

year, restore the data from a backup and proceed with the year-end close routine. 

 

  



 Year End Close Questions and Answers GP v10.0 

 

  Page 10 of 18   
© Copyright Professional Advantage 2014. 

General Ledger 

Q1.  Does the Year End Closing have to do be done right at year end?  

A1.  No the General Ledger Year End Closing is date sensitive and does not have to be run right at year end. 

You can start entering transactions in the new financial year. However, beginning balances for the new 

financial year will not be shown until you run the year end routine.   

Q2. How do I setup my next financial year in order to begin processing in the next financial year?  

A2. To setup your next financial year follow these steps:  

� Go to Tools >Setup > Company > Financial Periods.  If the year you want is not in the Year drop down 

box, enter that year; make sure the number of periods, the first day and the last day are correct for the 

year and then select Calculate. 

� Check that the begin date for each of the periods is correct. 

� At this point you can change the Period Name from Period 1 to a more descriptive name if you require. 

� Select OK 

� You can now select the Tax Periods button and do the same for your tax year. 

Q3. Can I post adjusting entries to a closed year? 

A3. Adjusting entries that need to be made after the close of the year can be made and posted to the most 

recent closed year. Make sure Allow Posting to History and Maintain History are marked in General Ledger 

Setup (Tools >Setup > Financial > General Ledger). If an entry is posted to the closed year, a second entry 

will automatically be made at that time to update the beginning balances that were set up for the new-year 

during the Year End Close. You can only post to into the closed year if the financial period 12 is open in the 

closed year. Also, you can only post back to the most recent historical year. 

The following is an example of posting an adjusting entry after closing the fiscal year.  

Example of Adjusting Entry:  

20/6/04    Administration Expenses  $500.00         

    Cash     $500.00  

 

Example of Posting Journal:  

20/6/04    Administration Expenses  $500.00  

    Cash     $500.00  

30/6/04    Retained Earnings   $500.00  

    Cash     $500.00     
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Q4. I have these Retained Earnings Accounts setup in my Chart of Accounts:  

100-3300-00 Retained Earnings Division 100  

200-3300-00 Retained Earnings Division 200  

300-3300-00 Retained Earnings Division 300  

How can I close my net income/ loss to the appropriate retained earnings accounts?  

A4.  This can be done with the use of Divisional Retained Earnings accounts on the General Ledger setup 

window (Tools > Setup > Financial > General Ledger). Marking this checkbox allows you to divide the net 

income or net loss amount among two or more retained earnings accounts. Segments are used to determine 

how the retained earnings will be divided. 

Select the segment that you want to use to identify between the accounts and which retained earnings 

account they are closed to (In the above example this would be the Division specified in Segment 1). Then in 

the Account field select one of your Retained Earnings accounts (In the above example this would be 3300). 

The other retained earnings are determined by substituting the specified segment into this account format.   

Q5. What happens to Unit Accounts during a Year-End Closing?  

A5. Unit Accounts are treated as Balance Sheet Accounts and will have a balance brought forward when the 

year is closed. If you would like to have the unit Accounts zero out at the beginning of the year you can run 

the following SQL script from within Query Analyser against the Company database (NOTE: Make a backup of 

the Company database before executing this statement):  

delete GL20000  

from GL00100, GL20000 

where GL00100.ACTINDX = GL20000.ACTINDX 

and GL00100.ACCTTYPE = 2 

and GL20000.SOURCDOC = 'BBF' 

Reconcile the open year in Dynamics GP (Tools >Utilities > Financial > Reconcile) after running this query. 

Q6. The following alert message appears when I attempt to close the year in General Ledger: ‘Sorry, 

another user is closing the year’. No one else is closing the year. What should I do?  

A6. The following SQL script needs to be run from within Query Analyser. ALL users must be out of the 

system:  

USE TEMPDB 

GO  

DELETE DEX_LOCK  

DELETE DEX_SESSION  

USE DYNAMICS 

GO 

DELETE ACTIVITY 

DELETE SY00800 

DELETE SY00801  
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Q7. I started the Year End Close process in General Ledger and a warning message appears. It says ‘A 

single-use batch or quick journal transaction has not been posted yet. Do you wish to continue 

closing?’ What should I do? 

A7. This message appears if you have unposted batches in General Ledger. If the batches need to be posted 

before closing the Year End, choose Cancel. Then go to Transactions > Financial > Batches and post the 

batches. If the batches do not need to be posted before closing the Year End, choose Continue.  

NOTE: A reason you may not want to post the batch is that it contains transactions for the new financial year.  

Q8. I am performing the Year End Close in General Ledger and it appears to be hanging at 50%. It 

looks like my workstation has locked up. What should I do?  

A8. If your Year to Date Transaction Open file is large, if may take a while for the Year End Closing procedure 

to complete. If your hard drive is still processing, it is not locked up and you should leave it running. If you 

hard drive is not processing you should restore a backup, do File Maintenance on all files in the Financial 

series (File > Maintenance > Checklinks; Series: Financial) and start the Year End Close again.  

Q9. If an adjustment is posted to a closed year, can I print a corrected Trial Balance for that year?  

A9. Yes, setup a new Report Option for the Trial Balance (Reports > Financial > Trial Balance). Change the 

Year to History and choose the closed year. The Historical Trial Balance will include any adjustments posted 

to the closed year.  

Q10. After closing the Year End I have found that I had an account setup with the incorrect Posting 

Type.  What are the implications of this and how can I correct it?  

A10. The implication is that your beginning balances for the new financial year will be incorrect for that 

account.  See the following information on how to correct this situation: 

Profit and Loss Account Set Up as a Balance Sheet Account 

If someone has a Profit and Loss account setup as a Balance Sheet account, the Profit and Loss 

Account will have a beginning balance after the Year End close. To correct this situation use the 

following steps. 

1. Make a backup. 

2. Be sure that the account(s) is still set to the INCORRECT Posting Type. 

3. If Multicurrency IS a registered module, go to Multicurrency Setup (Setup - Financial - Multicurrency) 

and unmark Maintain History for General Ledger Accounts. If Multicurrency IS NOT a registered 

module, you will not be able to perform this step.  Modify the Multicurrency Setup table by running the 

following SQL query against the company database: 

 UPDATE MC40000 SET MNSUMHST = 0   

 

(NOTE: To determine whether or not you are registered for Multicurrency go to Help > About 

Microsoft Business Solutions Great Plains > Options; If the Multicurrency Management checkbox is 

ticked then you are registered for Great Plains)   

 

4. Go to Setup > Financial > General Ledger and unmark Maintain History for Accounts and 

Transactions. 

5. In this same window, be sure Allow Posting to History is marked. Choose OK to save the changes. 
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6. Go to Transactions > Financial > General and enter the appropriate journal entry. Be sure the 

transaction date is in the closed year so that the entry goes into history. 

For example, if the Profit and Loss Account has a debit beginning balance after the year end close, you 

would make an entry similar to the one below: 

   Retained Earnings   Debit 

   Profit and Loss Account    Credit 

 

Enter one transaction for each account with an incorrect posting type. 

 

 

7. Post this entry. The posted transaction(s) will only affect the current year because we have turned off 

the maintaining history options. It will post a beginning balance transaction into the new financial year 

and therefore the accounts will now have the correct balances. 

8. Go to Setup > Financial > General Ledger and remark Maintain History for Accounts and 

Transactions. 

9. In this same window, be sure that Allow Posting to History is set correctly. Choose OK to save the 

changes. 

10. If Multicurrency IS a registered module, go to Multicurrency Setup (Setup > Financial > 

Multicurrency) and remark to Maintain History for General Ledger Account. If Multicurrency IS NOT 

registered, modify the Multicurrency Setup table by running the following SQL query against the 

company database: 

 UPDATE MC40000 SET MNSUMHST=1 

 

 11. Go to Cards > Financial > Account and bring up the account(s) with the incorrect Posting Type and 

change the posting type to the correct one. 
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Balance Sheet Account Set Up as a Profit and Loss Account 

If someone has a Balance Sheet account setup as a Profit and Loss account, the Balance Sheet account 

will have a beginning balance of ZERO after the Year-End close. To correct this situation use the 

following steps: 

1. Make a backup. 

2. Be sure that the account(s) is set to the CORRECT Posting Type using the Account Maintenance 

window. 

3. If Multicurrency IS registered go into the Multicurrency Setup window (Setup > Financial > 

Multicurrency) and unmark Maintain History for General Ledger Account.  If not registered for 

Multicurrency, you will not be able to perform this step.  If you are running Dynamics C/S+ SQL, modify 

the Multicurrency Setup table by running the following SQL query against the company database: 

 update MC40000 set MNSUMHST = 0 

 

(NOTE: To determine whether or not you are registered for Multicurrency go to Help > About 

Microsoft Business Solutions Great Plains > Options; If the Multicurrency Management checkbox is 

ticked then you are registered for Great Plains)   

 

4. Go to Setup > Financial > General Ledger and unmark Maintain History for Accounts and 

Transactions. 

5. In this same window, be sure Allow Posting to History is marked. Choose OK to save the changes.  

6. Go to Transactions > Financial > General and enter the appropriate journal entry. Be sure the 

transaction date is in the closed year so that the entry will update beginning balances. 

If the balance sheet account should have a debit beginning balance, you would make an entry similar 

to the one below: 

  Balance Sheet Account  Debit 

  Retained Earnings  Credit 

 

Enter one transaction for each account that had an incorrect posting type. 

 

7. Post the transaction(s). The posting procedure will only affect the current year, because you've 

turned off the maintaining history options. It will post a beginning balance transaction in the new 

financial year and, therefore, the accounts will now have the correct balances. 

8. Go to Setup > Financial > General Ledger and remark Maintain History for Accounts and 

Transactions. 

 

9. In this same window, be sure that Allow Posting to History is set correctly. Choose OK to save your 

changes. 



 Year End Close Questions and Answers GP v10.0 

 

  Page 15 of 18   
© Copyright Professional Advantage 2014. 

10. If Multicurrency IS a registered module, go to Multicurrency Setup (Setup > Financial > 

Multicurrency) and remark to Maintain History for General Ledger Account. If Multicurrency IS NOT 

registered, modify the Multicurrency Setup table by running the following SQL query against the 

company database: 

 UPDATE MC40000 SET MNSUMHST=1 

 

11. Go to Cards > Financial > Account and bring up the account(s) with the incorrect Posting Type and 

change the posting type to the correct one. 

 

 

Q11.  I am missing a profit and loss account after running the year end close.  Why?  

A11.  During the year end close process accounts will be removed if they fit the criteria for deleting a posting 

account.  The account cannot have a balance, current activity, account history, or transaction history.  If this is 

the case and the account is marked as inactive under Cards > Financial > Accounts, then the account will be 

removed.  

Q12.   How large will my transaction log be when I run year end? 

A12.  To find the size that the transaction log will be for a year end close process, you need to find the 

number of records that are going to move the Year to Date Open table to the Account Transaction History 

table. To do this, run the following SQL statement in Query Analyser on the company database: 

select ((count(*)/1000)*2 + 50) 

as 'MB needed for Year End' 

from GL20000 

where OPENYEAR = XXXX 

(where the XXXX is equal to the four digit year that is being closed) 

Make sure you have enough available space for the process to complete. 

Q13.  I have a Recurring Batch in General Ledger. If I reset my next journal number during the Year 

End Close, what will happen to my Recurring Batches? 

A13.  The Recurring Batch will maintain its journal numbers. If you want to change the journal number of the 

Recurring Batch, the batch must be deleted and reentered with the journal number you want. Remember, 

you can not have duplicate journal numbers in the same year, with the exception of recurring batches. 

Q14. We just closed the year, now looking at the GL Trial Balance the ending balance for the last year 

does not equal the beginning balance for the current year. Why?  

A14.  You will need to re-create your Financial Period Setup File.  If the balances are still incorrect after 

following this procedure we would recommend restoring to a backup before the year end process was run. 

To re-create your fiscal period setup follow these steps: 

NOTE: Before following the instructions, make sure that you are maintaining transaction history, and that 

you have maintained this history in the past. If you have not been maintaining transaction history, running 
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a reconcile will have serious implications on the summary information that you view through inquiry, or on 

reports. During a reconcile, the summary information is reconciled to the detail (transaction) information. If 

there is no detail for the summary to reconcile to, and you proceed with the reconcile, then any summary 

information that you had will be lost. The only way to restore this would be from a backup. It is 

recommended that you have a good backup of your data before recreating the fiscal periods, or proceeding 

with the reconcile. 

NOTE:  Recreating Fiscal Periods will reset the Period Description.  If you have entered Period Descriptions 

(such as Period 1 to January) these items will be reset.   

 

1. Make a printout of the fiscal periods by going to Reports > Company > Setup and print the Fiscal Period 

Report. Pay special attention to the years that are marked as history. 

2. Run the following statement against the Company Database you are having the problem with:  

delete SY40100 

delete SY40101 

3. In Great Plains go into Setup > Company > Fiscal Periods and set up each of the fiscal periods based on 

the report printed in Step 1.  

To do this: 

a. Type a year into the Year Pull Down List area. 

b. Fill in the Date of the First Day and Last Day of that Fiscal Year.  

c. Type in the Number of Periods for the Fiscal Year. 

d. Be sure to mark Historical Year if it is a history year on your printout. This step is very important. 

e. When completed with a year, click on the Calculate Button. 

f. Repeat the steps a-e for each of the years on your printout.  

 

4. When you're finished setting up all of the Fiscal Periods, click the OK Button. 

5.  Go to Utilities > Financial > Reconcile, and check the Year box. If you have history years in your fiscal 

periods, click on the History Button and pull up your oldest history year first. (If you have 2001,  2002, and 

2003 as history years, you would do 2001 first.) If you have no history years, start with your oldest open 

year. 

6. Click on Reconcile. The system will now go through all of the GL accounts and reconcile the account 

summary information to the account detail. 

7. Repeat steps 5 and 6 until you have gone through all of your history and open years in the correct order. 
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Q15.  Must I perform the sub-ledger year end closing routines before I close the General Ledger year 

end routine? 

A15.  No, it is not a requirement of Great Plains that the sub-ledgers be closed before the General Ledger 

year end is run. Please see details in the sub-ledger year end routines for more information about why you 

may want to close these first. 

Q16.  I am attempting to close the year in General Ledger and received the following error message: 

"Retained Earnings Account Not Found." 

A16.  When closing to Divisional Retained Earnings accounts, be sure you have a Retained Earnings account 

set up for each Division, even if those accounts do not have a current balance. Dynamics GP has to see a 

Retained Earnings account for each Division, otherwise, the Year -End closing process will not be completed.  

To determine which accounts have not been created run the attached SQL script from SQL Query Analyser 

against the Company database 

NOTE: Before running this script the field XXXX must be replaced with the account number that is being used 

for the retained earnings accounts. This can be found under Financial > Setup > General Ledger. This will 

display the segments that do not have a retained earnings account setup. 

set nocount on 

go 

select * into ##RETEMP  

 from GL00100 where ACTNUMBR_2 = 'XXXX' 

go 

select distinct(ACTNUMBR_1) into ##UNITTEMP 

 from GL00100 

go 

set nocount off 

go 

 

SELECT ACTNUMBR_1 FROM ##UNITTEMP WHERE ACTNUMBR_1 

NOT IN (SELECT ACTNUMBR_1 FROM ##RETEMP) 
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Q17. Must I specify a Posting Account for the Retained Earnings Account on the General Ledger Setup 

(Tools >Setup > Financial > General Ledger) window?  

A17.  The retained earnings account that you specify can either be a Posting Account or a Fixed Allocation 

account that has postings accounts as it distribution accounts.  

 

Q18. Why does the Last Closing Date field on the Year End Closing window (Tools >Routines > 

Financial > Year End Closing) represent?  Should I be concerned that this is not a date in my historical 

year?  

A18. The date in this field represents the system date when the year-end closing was performed. It is not 

necessary to change your system date when running the Financial Year End close as this routine is date 

sensitive. This will not cause any problems when next closing your year, Great Plains will only look at the Year 

specified on this screen and this is the Financial Year that will be closed.  

Q19. How do I create a period 13 for adjustments entries after the year end has been completed? 

A19. Before adding the 13th period you need to determine if you have already posted into June 30th (in this 

example the last day of the financial year).  If you have you will need to make the 13th period start date the 

1st July and start your next financial year from the 2nd of July. 

 To add the 13th period to your financial year: 

1.  Setup >Company >Financial Periods 

2.  Change the number of periods to 13 

3.  Then go to the thirteenth period and change the date to the 30/06/20XX.  (NOTE: When you click on 

recalculate it will change the start date of all your periods and you will need to go back to each one and re-

enter the correct start date) 

4.  You can changed the 13th period name to EOY Adjustments if required. 

5.  After clicking on OK you will be asked to run reconcile on the PM and RM sub-ledgers and the General 

Ledger. Run it on the sub-ledgers first. 

 

 

 


